Knowledge Base

Резервирование канала Mikrotik ltAP mini LTE kit Router OS v7.1.1

  1. Вставить сим-карты. 1 — слот приоритетный МТС, 2-й резервный Мегафон
  2. Работает только одна сим-карта
  3. Перейти в Interfaces -> LTE -> LTE APns -> Add default APN (internet)
  4. Добавить скрипт в System -> Scripts с названием failoverScript
  5. в Scheduler new task — /system scheduler add interval=3m on-event=failoverScript name=SIM Switch
 
 

{
:global initTimeout 60
:global connectTimeout 60
:global minimumSignalLevel -99

:global switchSIM do={
:local simSlot [/interface lte settings get sim-slot]

:if ($simSlot=»down») do={
:log info message=»Switching to \»up\» sim slot (MTS)»
/interface lte settings set sim-slot=up
} else={
:log info message=»Switching to \»down\» sim slot (Megafon)»
/interface lte settings set sim-slot=down
}
}

:global initialize do={
:global initTimeout

:local i 0
:while ($i < $initTimeout) do={
:if ([:len [/interface lte find]] > 0) do={
:return true
}
:set $i ($i+1)
:delay 1s
}

:return false
}

:global waitConnect do={
:global connectTimeout

:local i 0
:while ($i < $connectTimeout) do={
:if ([/interface lte get [find name=»lte1″] running] = true) do={
:return true
}
:set $i ($i+1)
:delay 1s
}

:return false
}

:if ([$initialize] = true) do={
:if ([$waitConnect] = true) do={
:local info [/interface lte monitor lte1 once as-value]
:local rspr ($monitor->»rspr»)
:if ($rspr < $minimumSignalLevel) do={
:log info message=(«Current RSPR «.$rspr.» < «.$minimumSignalLevel.». Trying to switch active sim slot.»)
$switchSIM
}
} else={
:log info message=»GSM network is not connected. Trying to switch active sim slot.»
$switchSIM
}
}
}